AndrewGuyGuyson
21.03.2023 20:38

Написать программу в pascalabc.net удалить из строчки s символы + - * а потом заменить все символы на символы следующие по алфавиту.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ruuuuuyslan
07.10.2020 11:04
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('Введите строку:');
  s:=s.RegexReplace('[\+\-\*]',''); // удалили
  s:=s.Select(c->Chr(Ord(c)+1)).JoinIntoString(''); // заменили
  Writeln(s)
end.

Пример:
Введите строку: Мой пример: 23+18.4*(3.1-0.15)=52.7 Is it true?
Нпк!рсйнжс;!3429/5)4/21/26*>63/[email protected]
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота