diman122001
26.10.2022 19:46

Написать программу, которая задает пользователю вопрос о том, какую фигуру тот выбирает: прямоугольник, или треугольник. после того, как пользователь выберет фигуру, программа интересуется, что он хочет найти для данной фигуры: площадь или периметр. после того, как пользователь выберет величину, которую хочет посчитать, программа запрашивает данные для подсчета величины данной фигуры. на с++

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Slysly
07.10.2020 11:19
#include <iostream>

using namespace std;

int main()
{
    int n, k, a, b, c, h;
    setlocale(LC_ALL, "rus");
    cout << "Выберите фигуру \n";
    cout << "1 - Треугольник \n";
    cout << "2 - Прямоугольник \n";
    cin >> n;
    cout << "Площадь или периметр \n";
    cout << "1 - Площадь \n";
    cout << "2 - Периметр \n";
    cin >> k;
    if (n == 1) {
        if (k == 1) {
            cout << "Введите длину основания: ";
            cin >> b;
            cout << "Введите высоту: ";
            cin >> h;
            cout << "S = " << b * h * 0.5 << '\n';
        }
        if (k == 2) {
            cout << "Введите 3 стороны:" << '\n' << "a: ";
            cin >> a;
            cout << '\n';
            cout << "b:";
            cin >> b;
            cout << "/nc: ";
            cin >> c;
            cout << "P = " << a + b + c << '\n';
        }
    }
    if (n == 2) {
        if (k == 1) {
            cout << "Введите длину: ";
            cin >> a;
            cout << "Введите ширину: ";
            cin >> b;
            cout << "S = " << a * b << '\n';
        }
        if (k == 2) {
             cout << "Введите длину";
            cin >> a;
            cout << "Введите ширину: ";
            cin >> b;
            cout << "P = " << 2 * (a + b) << '\n';
        }
    }
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота