России5544
08.05.2022 12:09

Вмассив с клавиатуры вводятся результаты соревнований по многоборью 7 спортсменов (значениея результатов от 1000 до 2000 ). составить программу которая находит номер и результат победителя

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kobyarova2001
07.10.2020 13:22
Var
  A: array[1..7] of integer;
  i: byte;
  Max, MaxInd: integer;
begin
writeln('Заполнение массива. Вводите числа от 1000 до 2000.');
for i := 1 to 7 do
begin
  write('A[',i,']=');
  readln(A[i]);
  if A[i] > Max then
  begin
    Max := A[i];
    MaxInd := i;
  end;
end;
writeln;
writeln('№ победителя ', MaxInd, ' результат = ', Max, ' .' );
end.

Вмассив с клавиатуры вводятся результаты соревнований по многоборью 7 спортсменов (значениея результ
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота