198219821982
17.05.2020 11:07

Нужно написать программу на c (ну или хотя бы на c++)‼️‼️‼️‼️‼️‼️‼️ дана строка символов, состоящая из произвольного текста,слова разделены пробелами.вывести на экран порядковый номер слова, накрывающего к-ю.(если на k-ю позицию попадает пробел, то гомер предыдущего слова)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
bilainфом
07.10.2020 13:51
#include <iostream>using namespace std; int main(){     char str [] = "dd yhd yw dcjkayt dvqv auyj fbajk dyusdv sddw";     int k = 9; //position     int before=  0, after = 0, space = 0;                         for(int i = 0; i <= k; i++){             if(str[i] == ' '){                 space++;             }         }         if(str[k] != ' '){       for(int i = k + 1; str[i]; i++){         if(str[i] == ' ' || str[i] == '\0'){             after = i;                         break;                 }         }         for(int j = k - 1; j >= 0; j--){         if(str[j] == ' ' || j == 0){             before = j;                         break;                 }     }         cout<<space + 1<<" slovo ";         for(int i = before; i < after; i++)         cout<<str[i];         }         else cout<<space<<" slovo"; return 0; }
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота