alina1930
27.10.2022 21:28

Вшколе n учеников 9 класса писали пробный экзамен по . составить программу, подсчета количества 2,3,4,5, полученных за экзамен. считайте оценку ученика случайным числом из диапазона от 2 до 5.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
2345678234567
07.10.2020 13:44
Var
  A: array[1..200] of byte;
  i, N, cTwo, cThree, cFour, cFive: byte;
begin
write('Введите количество учеников(N): '); readln(N);
randomize;
writeln('Все оценки за экзамен.');
for i := 1 to N do
begin
  A[i] := random(4)+2;
  if A[i] = 2 then cTwo := cTwo + 1;
  if A[i] = 3 then cThree := cThree + 1;
  if A[i] = 4 then cFour := cFour + 1;
  if A[i] = 5 then cFive := cFive + 1;
  write(A[i], ' ');  
end;
writeln('');
writeln('Оценку 2 получили ', cTwo, ' уч.');
writeln('Оценку 3 получили ', cThree, ' уч.');
writeln('Оценку 4 получили ', cFour, ' уч.');
writeln('Оценку 5 получили ', cFive, ' уч.');
writeln;
end.

Вшколе n учеников 9 класса писали пробный экзамен по . составить программу, подсчета количества 2,3,
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота