delfin4
15.05.2020 22:14

Составить блок схему и написать программу которая находит сумму цифр четного четырехзначного числа либо произведение нечетного четырехзначного числа

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
liudmilka19091982
07.10.2020 18:30
Программа:
program abc;
var x,s,p:integer;
begin
writeln('Введите четырехзначное число');
readln(x);
if (x mod 2)=0 then
begin
  s:=(x mod 10)+(x div 10 mod 10)+(x div 100 mod 10)+x div 1000;
  writeln('s=',s);
  end
else
  begin
  p:=(x mod 10)*(x div 10 mod 10)*(x div 100 mod 10)*x div 1000;
  writeln('p=',p);
  end;
end.
Блок-схема

Составить блок схему и написать программу которая находит сумму цифр четного четырехзначного числа л
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота