zcwe16
04.10.2022 06:16

Составить программу, считывает 2 числа, если сумма этих чисел кратно 3, то результат уменьшает в 3 раза, в противном случае оставляет без изменений.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
magauiyaa
07.10.2020 19:49
На c++, если тебе надо считывание с файла, то ответь я переделаю.

#include <iostream>using namespace std;int main(){ int a,b; cin>>a>>b; if((a+b)%3==0) cout<<(a+b)/3<<endl; else cout<<a+b<<endl; return 0;}
0,0(0 оценок)
Ответ:
romakirill1999
07.10.2020 19:49
// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,b):=ReadInteger2('Введите через пробел два числа');
  var r:=a+b;
  if r mod 3=0 then Writeln(r/3)
  else Writeln(r)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота