Николо223
25.10.2022 12:21

составьте программу на паскаль для решения : определите номер квадрата, в котором находится точка с заданными координатами.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
H1e1l1p
06.02.2021 02:27

"Написать программу,которая вводит массив из N целых чисел и выводит на экран элементы с чётными индексами(индексация начинается с нуля). Протестировать программу на произвольных массивах размерностью 5 и 8 элементов."

 

Для программы с 8-ми элементным массивом нужно const int n = 5 изменить на const int n = 8

 

#include <iostream>
using std::cout;
using std::cin;
using std::endl;

int main()
{
    const int n = 5;
    int a[n];

    cout << "Enter 5 numbers: ";

    for(int i = 0; i < n; i++)
    {
        cin >> a[i];
    }

    for(int i = 0; i < n; i++)
    {
        if(i % 2 == 0)
        {
            cout << a[i] << ' ';
        }
    }
    cout << endl;

   return 0;
}


Написать программу,которая вводит массив из n целых чисел и выводит на экран элементы с чётными номе
0,0(0 оценок)
Ответ:
surmistovak
06.02.2021 02:27

1)

var a:array [1..100] of integer; объявляем массив

i,n:byte; объявляем вс переменную i и переменную  n  для хранения количества элементов

 

begin

write('Введите n = ');readln(n); вводим n

for i:=1 to n do begin от 1 до n  цикл 

write('a[',i,']=');

readln(a[i]); вводим элементы в массив

end;

write('Исходный массив: ');

for i:=1 to n do выводим наш массив полностью

write(a[i],' ');

writeln;

write('Результат: '); выводим результат, в данном случае все элементы стоящие на четных местах

for i:=1 to n do

if i mod 2 =0 then write(a[i],' '); проверка на четность, мод - это оператор деления по остатку, если индекс делится на 2 без остатка, то выводим элемент

end.

 

2)

var a:array [1..100] of integer;

i,n:byte; s:longint; s объявляем для хранения суммы элементов

 

begin

s:=0; обнуляем s

write('Введите n = ');readln(n);  тут тоже самое, что и в первой задаче

for i:=1 to n do begin

write('a[',i,']=');

readln(a[i]);

s:=s+a[i]; вот здесь мы складываем каждый элемент массива в переменную s

end;

write('Исходный массив: ');

for i:=1 to n do  вывод массива

write(a[i],' ');

writeln('Сумма всех элементов массива = ',s); вывод суммы

end.

 

Удачи=)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота