Марси667
25.06.2022 23:37

Все сови : написать программу котораяопределяет является ли число четнымили его запись окончательно целая 7

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
eduard7286
07.10.2020 20:18
Var
num: integer;
begin
read(num);
if num mod 2 = 0 then write('Число четное') else write('Число нечетное');
end.
0,0(0 оценок)
Ответ:
rikgetikov
07.10.2020 20:18
Var
  n:integer;

begin
  Write('n = '); Read(n);
  if (n mod 2=0) then Writeln('Число четное')
  else begin
    Write('Число нечетное и оно ');
    if Abs(n mod 10)<>7 then Write('не ');
    Writeln('оканчивается цифрой 7')
    end
end.

Примеры
n = 3538
Число четное

n = 642301
Число нечетное и оно не оканчивается цифрой 7

n = 6306547
Число нечетное и оно оканчивается цифрой 7

n = -546347
Число нечетное и оно оканчивается цифрой 7
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота