Katykpoper
01.04.2023 22:22

Составьте программу вычисления выражения (разными применяя каждый из операторов while,repeat,for) a^p, где p - целое число. pascal / надо.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
диван111111
04.08.2020 10:00
1)Это с

var a,p,i,c:integer;
begin
  readln(a);
  readln(p);
  c:=1; i:=0;
  while i<p do
  begin
    c:=c * a;
    inc(i);
  end;
  writeln(c);
  readln;
end.

2) Это с

var a,p,i,c:integer;
begin
  readln(a);
  readln(p);
  c:=1; i:=0;
  repeat
    c:=c * a;
    inc(i);
  until i=p;
  writeln(c);
  readln;
end.

3) Это с

var a,p,i,c:integer;
begin
  readln(a);
  readln(p);
  c:=1;
  for i:=1 to p do
    c:=c * a;
  writeln(c);
  readln;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота