влад2162
07.09.2021 03:07

Составить программу, которая проверяет является ли билет счастливым. в билете 6 цифр. 8 !

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
moonmyrreg
21.08.2020 10:12
//PascalABC.NET
//Версия 3.3, сборка 1627
begin
var a:=ReadString();
write(a.SkipLast(3).Select(x->x.ToDigit()).Sum()=a.Skip(3).Select(x->x.ToDigit()).Sum());
end.
0,0(0 оценок)
Ответ:
мотя104
21.08.2020 10:12
Var
a,sum1,sum2,i:longint;
begin
Readln(a);
for i:= 1 to 3 do
  begin
    sum1 := sum1 + a mod 10;
    a:= a div 10;
  end;
for i:= 1 to 3 do
  begin
    sum2 := sum2 + a mod 10;
    a:= a div 10;
  end;  
if (sum1 = sum2) then Writeln('YES')
  else Writeln('NO');
end.

Пример:
123321
YES
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота