Sergo12345678910
16.03.2021 08:53

Паскаль: дан текст. слова в тексте разделены одним или несколькими пробелами. написать программу, выводящую все слова, начинающиеся с гласных букв алфавита.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Кисулятв
07.10.2020 22:08
var
i:integer;
s:string;
const
glas=['Й','У','Е','Ы','А','О','Э','Я','И','Ю'];
beginwrite ('Vvedite predlohenie: ');
readln (s);
i:=1;
while i<=length (s) do     
begin           
if ((i=1) or (s[i-1]=' ')) and (s[i] in glas) then           
begin             
while not ((s[i] in ['.',',',';','!','?',':',' '])) and (i<=length (s)) do                   
begin                         
write (s[i]);                         
i:=i+1;                   
end;             
writeln;           
end;         
i:=i+1;     
end;
readln;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота