alenabovkun
05.02.2021 12:27

нужно написать программу которая выводит наибольшую цифру в введенном числе.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
anna47983
08.10.2020 00:03
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (n,dmax):=(Abs(ReadInteger('n=')),0);
  while n>0 do begin
    var t:=n mod 10;
    if t>dmax then dmax:=t;
    n:=n div 10
    end;
  Writeln(dmax)
end.

Пример
n= 2450234
5
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота