MrSwister
31.10.2020 03:47

Написать программу, которая определяет, к какой четверти плоскости принадлежит точка с координатами х, у? паскаль

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
oleshko05
21.08.2020 11:03
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (x,y):=ReadReal2('Введите  координаты точки x и y:');
  if x=0 then begin
    if y=0 then Writeln('Точка лежит в начале координат')
    else Writeln('Точка лежит на оси ординат (y)');
    exit
    end
  else
    if y=0 then begin
      Writeln('Точка лежит на оси абсцисс (х)');
      exit
      end;
  if x>0 then
    if y>0 then Writeln('Точка принадлежит I четверти')
    else Writeln('Точка принадлежит IV четверти')
  else
    if y>0 then Writeln('Точка принадлежит II четверти')
    else Writeln('Точка принадлежит III четверти')
end.

Пример
Введите  координаты точки x и y: 12.4 -7
Точка принадлежит IV четверти
0,0(0 оценок)
Ответ:
tkalenko03
21.08.2020 11:03
 var   
x,y : integer;    
begin  
readln (x,y);  
if (x=0) or (y=0) 
then   
begin    
if x = 0 then
     writeln ('Точка лежит на оси y');    
if y = 0 then
     writeln ('Точка лежит на оси x')'   
end  
else  
 begin 
   if (x>0) and (y>0) then
     writeln ('Точка находится в первой четверти');  
   if (x<0) and (y>0) then
     writeln ('Точка находится во второй четверти'); 
   if (x<0) and (y<0) then
     writeln ('Точка находится в третей четверти'); 
   if (x>0) and (y<0) then
     writeln ('Точка находится в четвертой четверти');
  end; 
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота