Войти
Регистрация
Спроси ai-bota
velikayadasha
24.02.2020 10:19
С++ напишите программу, которая выводит на экран все цифры числа, начиная с первой. допустим, вводишь 123, а программа выводит 1 2 3.
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
vbbbbb
04.01.2023 09:52
Розрахуйте мінімально необхідну швидкість підключення до мережі Інтернет, яка дозволить переглядати відео з мережі у он-лайн режимі без затримок, якщо відомо, що відеофайл...
whitesnaff
14.10.2020 16:23
Определите количество символов в сообщении, алфавит которого состоит из 256 символов, информационный объем равен 1640 бит...
Akri2532
11.10.2020 09:36
Что надо делать в паскале что бы вывести например числа оканчивающиеся на 4 ? я знаю х mod 10 = 4 но с отрицательными это не действует, что делать?...
Ученик12090
01.04.2020 20:13
Выберите верные факты об абу аль-хорезми. выберите несколько из 5 вариантов ответа: 1) сформулировал правила выполнения арифметических действий над целыми числами и...
Ravik2K
10.08.2022 00:57
Паскаль. длинная арифметика. нужно сложить два великих длинных числа....
IamInga18
23.09.2022 21:22
Постройте таблицу истинности для логического выражения B&(A V неB)...
ananimka456
30.06.2021 11:58
. Яка з наведених точок належить площині 0xy? А (-1; 2; 3) В (0; 2; 3) С (-1; 0; 3) D (-1; 2; 0) Е (0; 0; 3)...
yana603
02.12.2022 07:35
Переведите это на французский без онлайн переводчика .Сегодня воскресенье я встала в десять утра и пошла за кофе. После этого я возвращаюсь домой и завтракаю яичницой...
154Dance3
02.12.2022 07:35
Соотнесите термины и их определенияГунныПолудрагоценныйкаменьШаньюйТитул правителягунновНефритКочевой народПшенныезернаобъект,подвергавшийсявоздействиючеловека иобнаруженный...
Julia1965
02.12.2022 07:35
1. В одному ящику у 5 разів більше яблук, ніж у другому. Скільки яблук у кожному ящику, якщо у двох ящиках разом 144 кг яблук....
Ответ:
nastyaorelrus
08.10.2020 02:00
Один из простых методов.
#include <iostream>
void digits(const unsigned &val)
{
if (val) {
std::cout << (digits(val / 10), val % 10) << " ";
}
}
int main()
{
digits(123);
return 0;
}
0,0
(0 оценок)
Ответ:
dima140504
08.10.2020 02:00
#include <iostream>
#include <stack>
using namespace std;
void digits(int *num);
int main()
{
int num;
cin >> num;
void(*ptr)(int *num);
ptr = digits;
(*ptr)(&num);
return 0;
}
void digits(int *num)
{
stack<short int> stack;
while(*num>0)
{
stack.push(*num % 10);
*num /= 10;
}
while(!stack.empty())
{
cout << stack.top() << " ";
stack.pop();
}
}
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота