Dhcfyfhffdh
29.06.2022 23:56

Написать программу, которая запрашивает строку и выводит на экран 1-й, 2-й и 5-й символы. паскаль abc.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Sn00ру
08.10.2020 02:28
Var s:string;
begin
writeln('Введите строку:');
readln(s);
writeln('s[1] = ',s[1],', s[2] = ',s[2],', s[5] = ',s[5]);
end.

Пример:
Введите строку:
Microsoft
s[1] = M, s[2] = i, s[5] = o
0,0(0 оценок)
Ответ:
AnnWer
08.10.2020 02:28
Переводим строку в массив символов.По красоте можно создать отдельно массив.

var s : String;
begin
Read(s);
Writeln(s.ToCharArray()[0]);//число -1 т.к. начинается все с нуля
Writeln(s.ToCharArray()[1]);
Writeln(s.ToCharArray()[4]);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота