lizahelp7
29.03.2021 01:34

Составьте программу формирования массива в pascal ! 1 2 3 4 n 0 2 3 4 n 0 0 3 4 n 0 0 0 4 n 0 0 0 0 n 0 0 0 0 0

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
юлия1764
08.10.2020 06:08
Const n=5;
var a:array[1..n,1..n+1] of integer;
i,j:integer;
begin
for i:=1 to n do
 begin
 for j:=1 to n-i+1 do a[i,j]:=j+i-1;
 for j:=n-i+2 to n+1 do a[i,j]:=0;
 end;
for i:=1 to n do
 begin
 for j:=1 to n+1 do write(a[i,j]:2);
 writeln;
 end;
end.

Результат:
1 2 3 4 5 0
2 3 4 5 0 0
3 4 5 0 0 0
4 5 0 0 0 0
5 0 0 0 0 0
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота