Bossak
09.04.2023 10:06

Напишите программу которая вводит натуральное число n и выводит n квадратов из символов "@". ввод: 3 вывод: @@@ @@@ @@@ @ @ @ @ @ @ @@@ @@@ @@@

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Chocolateteapot0507
08.10.2020 06:25
{ ответ дан на языке Pascal }
PROGRAM Solution(INPUT, OUTPUT);

VAR
  n: INTEGER;
  I: INTEGER;
  Str: STRING;

BEGIN
  WRITE('Введите кол-во квадратов: ');
  READLN(n);
  STR := '@@@ ';
  FOR I := 2 TO n
  DO
  BEGIN
    Str := Str + COPY(Str, 1, 4);
  END;
  WRITELN(Str);
  WRITELN(Str);
  WRITELN(Str);
END.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота