iojhhjkl
08.06.2021 09:47

На вход программы поступает натуральное число, не превышающее 10^9 нужно написать программу, которая выводит на экран максимальную цифру числа, меньшую 5 если в числе нет цифр, меньших 5, требуется на экран вывести «no». в программе есть ошибки. var n, d, m: longint; begin readln(n); m : = n mod 10; while n > 0 do begin d : = n mod 10; if d < 5 then if d > m then m : = d; n : = n div 10; end; if m = 0 then writeln('no') else writeln( m ) end. последовательно выполните следующее. 1 напишите, что выведет эта программа при вводе числа 157 2 укажите наибольшее трёхзначное значение входной переменной n, при вводе которого программа выведет правильный ответ. укажите это ответ. 3 найдите в программе все ошибки (их может быть одна или несколько). для каждой ошибки выпишите строку, в которой она допущена, и эту же строку в исправленном виде.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
mrdaaly
08.10.2020 08:24
1) 7  - изза начального присвоение m
2) 994. 4 соответствует условию, остальные числа лишь максимизируют число
3)

var
    N, d, m: longint;

begin
    readln(N);
    {m := N mod 10; ошибочная строка}
    m:=-1; {N mod 10 - может не удовлетворять условию, 0 - может и удовлетворять условию }
    while N > 0 do
    begin
        d := N mod 10;
        if d < 5 then
            if d > m then m := d;
        N := N div 10;
    end;
    {if m = 0 then ошибочная строка}
    if m = -1 then {если в цикле m так не разу и не поменялась}
        writeln('NO')
    else writeln(m);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота