Войти
Регистрация
Спроси ai-bota
r8n73x9999
28.12.2021 01:42
Написать в c++ программу: ввести массив. найти произведение положительных элементов массива, стоящих после максимального элемента массива.
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Torlate
11.09.2020 10:38
Сколько памяти (Кбайт) нужно для хранения 64-цветного растрового графического изображения размером 32 на 128 пикселей? *...
handaa0615
10.07.2020 02:35
сделать Web-страничку в html-editor...
Машаrobotg
11.03.2023 17:01
Program usi; Var d,r: real; Begin writeln( ВЕДИТЕ ЧИСЛ ); Readln (d); if d 0.655 THEN write(r=sqrt(d)) else IF d =0.65 THEN write (r=3-2*d); readln(d) End. выдаёт ошибку:...
sp14
15.02.2023 21:48
Длина а-сторона квадрата найти и вывести периметр и площадь квадрата. составить программу...
Динара010
31.03.2023 23:55
Определите значение переменной «k» после выполнения фрагмента программы: a := 7; b := 8; k := 5+a; if a b then k := k*3 else k := k -3; write ln(k);...
alinakozina879
05.06.2021 01:23
Самым большим по количеству букв в книге рекордов Гиннеса зарегистрирован Кхмерский алфавит. В нём насчитывается 72 буквы. На этом языке говорят в Камбодже. Оцените, какое...
63344667876763823947
30.03.2021 05:16
, задание вроде лёгкое, но решается оценка в аттестат Здесь нужно чтобы одному числу удовлетворяло а другому нет, типо если s правильно, то подобрать такое минимальное...
nikitos3567
24.06.2022 21:20
Как программируется цикл с предусловием на паскале?...
qooperty
26.05.2021 06:25
Почему алгоритм вычисления n! должен быть циклическим?...
timirshan
25.04.2023 07:34
Запиши число 14685 в развёрнутом виде, начиная со старшего разряда...
Ответ:
TheGrigory
08.10.2020 08:55
// Compiler: G++ + Bionic
#include <iostream>
#include <cstdlib>
int main()
{
int max, ptr, num = 1;
int n; scanf("%d",&n);
int *m = new int[n];
for(int i = 0; i < n; i++){
scanf("%d",&m[i]),
max = (!i?m[0],ptr=0:(max<m[i]?m[i],ptr=i:max));
if(i+1==n)
for(int j = i; j >= ptr; j--)
num *= (m[j]>0?m[j]:1);
}
delete [] m;
printf("%d",num);
return EXIT_SUCCESS;
}
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота