9petya
17.07.2021 09:01

Программисты ! надо написать программу на паскале, найти произведение отрицательных элементов массива.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
А04рлан05
08.10.2020 09:40
Program n1;
var a: array[1..10] of integer;
i,p: integer;
begin
randomize;
write('массив: ');
p:=1;
for i:=1 to 10 do
begin
a[i]:=random(21)-10;
write(a[i],' ');
if a[i]<0 then p:=p*a[i];
end;
writeln;
write('произведение отрицательных: ',p)
end.
0,0(0 оценок)
Ответ:
снегурочка01
08.10.2020 09:40
PascalABC.NET 3.3.5, сборка 1650 от 01.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
  a.Where(t->t<0).Aggregate(BigInteger(1),(p,q)->p*q).Println
end.

Пример
n= 15
-44 -33 -7 48 14 44 -14 -14 -45 -13 16 47 -48 19 -14
-783151649280
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота