kocheryan86p08jni
23.05.2022 17:51

Напишите программу, которая заполняет матрицу размером 7 продолжение внизу прогу только для рисунка по середине

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
gennadih90
08.10.2020 12:08
Const   N = 7;Var   A:array[1..N,1..N] of integer;   i,j:integer;BeginFor i:= 1 to N do    Begin    For j:= 1 to N do        Begin        A[i,j]:=random(21)-10;        Write(A[i,j]:3,' ')        End;    WriteLn    End;WriteLn;For i:= 1 to N div 2+(N mod 2) do    Begin    For j:= 1 to N do        Begin        if (j<=N div 2+i)and(N div 2-i+(N mod 2)<j) then A[i,j]:=99;        Write(A[i,j]:3,' ')        End;    WriteLn;    End;For i:= (N div 2)+(N mod 2)+1 to N do    Begin    For j:= 1 to N do        Begin        if (i-N div 2-1<j)and(j<=N+N div 2+1-i) then A[i,j]:=99;        Write(A[i,j]:3,' ')        End;    WriteLn;    End;End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота