44444kobzarr1
23.06.2020 22:03

Напишите программу на с++, которая в последовательности натуральных чисел определяет сумму чисел, кратных 6 и оканчивающихся на 8. программа получает на вход количество чисел в последовательности, а затем сами числа. в последовательности всегда имеется число, кратное 6 и оканчивающееся на 8. количество чисел не превышает 100. ввёденые числа по модулю не привышают 300. программа должна вывести одно число: сумму чисел, кратных 6 и оканчивающихся на 8. пример: входные данные: 3 18 25 48 выход 66

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
SerPol
16.08.2020 22:25
#include "iostream"
#include <Windows.h>
#include <cmath>
using namespace std;

int main() {
setlocale(LC_ALL, "Russian");
int n, x;
int summ = 0;
int mas[100];
do {
   cout << "Введите количество чисел в последовательности от 1 до 100: ", cin >> n;
}
while (n < 1 && n > 100);
for (int i = 0; i < n; i++){
   do {
      cout << "Введите " << i << " число: ", cin >> x;
 } while (abs(x) > 300);
    mas[i] = x;
    if (x % 6 == 0){
    summ += x; } else
    if (x % 10 == 8){
    summ += x;
   }
}
cout << "Сумма чисел: " << summ << endl;
system("pause");
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота