09nika90
31.10.2020 02:27

Как в c++ написать программу, чтобы она спрашивала твоё имя, а затем здоровалась с тобой. я пишу, вроде всё правильно делаю, но программа выдает: "hello, 0", чтобы я не вводила. #include ; using namespace std; int main() { int name; cout < < "what is your name? "; cin > > name; cout < < "hello," < < name< < endl; return 0; }

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Seallk
08.10.2020 20:34
По порядку:
1) Ты забыл подключить библиотеку <iostream> (надо было наприсать
#include <iostream>)
2) int - тип целочисленных переменных - они могут принимать лишь значения, что не удивительно, целых чисел. Для твоей цели необходимо использовать строковую переменную, в C++ - это string (Для ее использования необходимо ее подключить - #include <string>)

Итого
#include <iostream>
#include <string>

using namespace std;

int main() {
string name;
cout << "What is your name?";
cin >> name;
cout << "Hello, " << name<< endl;
return 0;
}
0,0(0 оценок)
Ответ:
Semev
08.10.2020 20:34
Достаточно массива char str[10] и не нужно ничего лишнего подключать, прежде чем переходить к <string> из С++, стоить ознакомится со Си строками, тк <string> это только удобная обертка
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота