ziatiok2016p074n4
24.03.2021 04:31

Pascal: двухмерный массив. в метании молота состязается n спортсменов. каждый из них сделал m бросков. победителем считается тот спортсмен, у которого сумма результатов по всем броскам максимальна. если перенумеровать спортсменов числами от 0 до n-1, а попытки каждого из них - от 0 до m-1, то на вход программа получает массив a[n, m], состоящий из неотрицательных целых чисел. программа должна определить максимальную сумму чисел в одной строке и вывести на экран эту сумму и номер строки, для которой достигается эта сумма. входные данные программа получает на вход два числа n и m, являющиеся числом строк и столбцов в массиве. далее во входеом потоке идет n строк по m чисел, являющихся элементами массива. выходные данные программа должна вывести 2 числа: сумму и номер строки, для которой эта сумма достигается. если таких срок несколько, то выводится номер наименьшей из них. не забудьте, что нумерация строк (спортсменов) начинается с 0. примеры входные данные выходные данные 2 2 9 5 4 1 3 5

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
sveta998
08.10.2020 20:44
PascalABC.NET 3.4.0, сборка 1671 от 31.05.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (n,m):=ReadInteger2;
  var a:=ReadMatrInteger(n,m);
  var i:=a.Rows.Select(row->row.Sum).ToArray.IndexMax;
  Writeln(a.Row(i).Sum,' ',i)
end.

Pascal: двухмерный массив. в метании молота состязается n спортсменов. каждый из них сделал m броско
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота