kotgemer
21.03.2020 19:25

Паскаль.авс
заданы три точки на плоскости a(x1,y1), b(x2,y2) и c(x3,y3). нужно определить, можно ли провести треугольник через эти три точки. если да, то составьте программу вычисления площади по формуле герона.
паскаль

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
varyatitova20
08.10.2020 21:08

function len(A, B: (integer, integer)): real;

begin

 result := Sqrt((A[0] - B[0]) ** 2 + (A[1] - B[1]) ** 2);

end;

function geron(a, b, c: real): real;

begin

 var p := (a + b + c) / 2;

 result := Sqrt(p * (p - a) * (p - b) * (p - c));

end;

begin

 var (x1, y1) := ReadInteger2(); // или ReadReal2() на ваш выбор

 var (x2, y2) := ReadInteger2();

 var (x3, y3) := ReadInteger2();

 var a := len((x1, y1), (x2, y2));

 var b := len((x2, y2), (x3, y3));

 var c := len((x1, y1), (x3, y3));

 if a + b + c > max(a, max(b, c)) * 2 then

   Writeln(geron(a, b, c))

 else

   Writeln('треугольник не существует')

end.

Объяснение:


Паскаль.авс заданы три точки на плоскости a(x1,y1), b(x2,y2) и c(x3,y3). нужно определить, можно ли
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота