клубочек333
26.06.2021 12:55

Написать программу, которая подсчитывает количество положительных и отрицательных элементов файла целых чисел des.dat. pascal abc

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Yogurt1958
08.10.2020 21:17
Var
  f:file of integer;
  i,n,kp,ko:integer;
begin
  { создать файл }
  randomize;
  assign(f,'des.dat');
  rewrite(f);
  for i:=1 to 20 do
  begin
    n:=random(101)-50;
    Write(n,' ');
    Write(f,n)
  end;
  close(f);
  Writeln;
  { работа с файлом }
  ko:=0;
  kp:=0;
  reset(f);
  while not eof(f) do
  begin
    Read(f,n);
    if n>0 then Inc(kp)
    else if n<0 then Inc(ko)
  end;
  close(f);
  Writeln('Положительных ',kp,', отрицательных ',ko)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота