olenkadergunov
13.04.2023 19:36

Написать программу вычисляющую чётность нечётность цифр и так чтобы при вводе нуля писалось что так делать нельзя !

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Ecli
08.10.2020 23:09

// PascalABC.NET 3.4.2, сборка 1785 от 06.09.2018

// Внимание! Если программа не работает, обновите версию!

begin

 var n:=Abs(ReadInteger('Введите целое число:'));

 if n.IsOdd then Println('Число нечетное')

 else

   if n=0 then Writeln('Ноль вводиить нельзя')

   else Println('Число четное')

end.

0,0(0 оценок)
Ответ:
АлиOчкА
08.10.2020 23:09

#include <iostream>



int main()

{

   int x;

   std::cout << "Введите число, которое нужно проверить: ";

   std::cin >> x;

   

   if(x == 0)

       std::cout << std::endl << "Нельзя писать такое число!";

   else if(x % 2 == 0)

       std::cout << std::endl << "Четное";

   else if(x % 3 == 0 || x == 1)

       std::cout << std::endl << "Нечетное";

   return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота