Qweres2000
23.10.2022 22:27

Напишите программу, которая позволяет ввести три вещественных числа и выводит на экран: натуральный логарифм квадрата суммы первого и третьего чисел. все вещественные числа должны быть выведены в форме с фиксированной точкой с двумя знаками после запятой, перед каждым вычисленным значением должны идти пояснительный текст и выражение.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
шишловская
27.08.2020 08:25

// PascalABC.NET 3.4.2, сборка 1785 от 06.09.2018

// Внимание! Если программа не работает, обновите версию!

begin

 var (a,b,c):=ReadReal3('Введите три числа через пробел:');

 Write('Натуральный логарифм квадрата суммы первого и третьего числа ',

     Ln(Sqr(a+c)):0:2)

end.

0,0(0 оценок)
Ответ:
лолер2
27.08.2020 08:25

(*Объявление переменных*)

var

   var1,var2,var3, result:real;


begin

   (*Ввод значений*)

   readln(var1, var2, var3);

   

   (*Считаем натуральный лог. от квадрата суммы var1 и var3 *)

   result := ln((var1 + var2) * (var1 + var2));

   (*Выводим результат*)

   writeln('Результат = ', result:2);

   

   

   (*Выводим все введенные числа*)

   writeln('Число 1 = ', var1:2);

   writeln('Число 2 = ', var2:2);

   writeln('Число 3 = ', var3:2);

end.

fpc 3.0.0 - compiler



Напишите программу, которая позволяет ввести три вещественных числа и выводит на экран: натуральный
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота