DMITRIY184
07.06.2022 12:34

Все
pascal

2. информация о количестве жильцов в каждой из четырех квартир каждого этажа 12-
этажного дома хранится в двумерном массиве (в первой строке — информация о
квартирах первого этажа, во второй — второго и т. определить:
а) на каком этаже проживает меньше всего людей;
б) на каком этаже проживает больше всего людей.
обе решить двумя с использованием дополнительного одномерного массива;
2) без использования дополнительного одномерного массива.

3. в поезде 18 вагонов, в каждом по 36 мест. информация о проданных на поезд билетах
хранится в двумерном массиве, номера строк которого соответствуют номерам вагонов,
а номера столбцов — номерам мест. если билет на то или иное место продан, то
соответствующий элемент массива имеет значение 1, в противном случае — 0.
составить программу, определяющую, имеются ли свободные места в том или ином
вагоне поезда.

4. дан двумерный массив целых чисел. сформировать одномерный массив, каждый
элемент которого равен наибольшему по модулю элементу соответствующего столбца
двумерного массива.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
sopyryaeva1976
03.12.2021 08:40
Var N:Array[1..20] of integer; i,j,q,k,max:integer;begin Randomize;writeln('массив');for i:=1 to 20 do beginN[i]:= random(100)-50;write(N[i]:4);end;writeln;i:=0;writeln('Измененый массив');While j<20 do beginj:= j + 2; k := N[j-1];N[j-1]:=N[j]; N[j]:= k;end;foreach q in N do beginwrite(q :4);end;end.
var N,M:Array[1..20] of integer; i,j,min,q,k,max:integer;begin Randomize;max:=-200; min:=200;writeln('1 массив');for i:=1 to 20 do beginN[i]:= random(100)-50;write(N[i]:4);if ((N[i]>0 )and(N[i] mod 2 = 0))then beginif max < N[i] then max := N[i];if min > N[i] then min := N[i];j:= j + 1;M[j]:=N[i];end;end;writeln;writeln('2 массив');foreach k in M do beginwrite(k:4);end;writeln;if (max = -200) or (min = 200)  then write ('нет чётных положительных элементов')else beginwrite('max = ' ,max:4);write('  min = ' ,min:4);end;end.
1) заполните массив случайными числами и переставьте соседние элементы, поменяв 1-ый элемент со 2-м,
0,0(0 оценок)
Ответ:
medewwnik
05.09.2022 02:19
Я не знаком особо с паскалем, но могу направить на путь истинный :b
Кароче..
Подсчет количества:
если билет счастливый count++;
(все логично)
Но как определить счастливый ли билет:
Припустим у нас номер билета лежит в массиве: ticket, то
if ((strval(ticket[0]) + strval(ticket[1] + strval(ticket[2])) == (strval(ticket[3]) + strval(ticket[4]) + strval(ticket[5])))
count++;

strval - преобразовнаие из строки в число. string --> integer
Если синтаксис знаешь, то напишешь прогу, если нет.. то жди ответа других.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота