Rawree258
15.11.2021 02:50

Дан вещественный массив а[n][м], все элементы которого различны. в каждой строке найти элемент с наименьшим значением, а затем среди найденных элементов выбрать наибольший. вывести на экран индексы этого элемента. написать программу на с++

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
GaLat666
17.08.2020 06:57
Код

#include <bits/stdc++.h>

using namespace std;

int main() {

   int n, m;

   cin >> n >> m;

   double a[n][m];

   for (int i = 0; i < n; ++i)

     for (int j = 0; j < m; ++j)

       cin >> a[i][j];

   int mxi = 0, mxj = 0;

   for (int i = 0; i < n; ++i) {

     int mnj = 0;

     for (int j = 1; j < m; ++j)

       if (a[i][j] < a[i][mnj]) mnj = j;

     if (a[i][mnj] > a[mxi][mxj]) {

       mxi = i;

       mxj = mnj;

     }

   }

   cout << (mxi + 1) << " " << (mxj + 1) << endl;

   return 0;

}


ТестВвод:

4 5

1 2 3 4 5

0 1 2 3 4

0 0 0 0 -1

16 32 28 17 100

Вывод:

4 1

Пояснение:

Минимальные элементы в каждой строке: 1(1;1), 0(2;1), -1(3;5), 16(4;1)

Максимальным среди них является число 16, которое имеет координаты 4 1 (1-индексация).

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота