MonSlon
03.04.2022 12:30

Задан двумерный массив а из 2-х строк и 7-и столбцов. составить программу, которая организует одномерный массив, каждый элемент которого есть сумма элементов исходного в столбце. мне, ! , напишите полную программу для меня большое вам за !

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
герман2031
09.10.2020 13:24

var a:array[1..2,1..7] of integer;

b:array[1..7] of integer;

i,j,s:integer;

begin

for i:=1 to 2 do

begin

for j:=1 to 7 do

begin

a[i,j]:=random(10);

write (a[i,j]:2,' ')

end;

writeln

end;

writeln;

for j:=1 to 7 do

begin

s:=0;

for i:=1 to 2 do s:=s+a[i,j];

b[j]:=s;

end;

for i:=1 to 7 do write (b[i]:2,' ')

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота