DiModDi
24.02.2023 00:38

Дан символьный массив а[n][n]. найти все такие целые числа k, что k-я строка матрицы совпадает с k-м столбцом. написать программу на с++

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
DEMON8800
09.10.2020 14:36

#include <bits/stdc++.h>

using namespace std;

int a[1010][1010],n;

bool sovp(int x) {

for (int i = 1; i <= n; i++)

 if (a[x][i] != a[i][x]) return 0;

return 1;

}

main () {

cin >>n;

for (int i = 1; i <= n; i++)

 for (int j = 1; j <= n; j++)

  cin >>a[i][j];

for (int i = 1; i <= n; i++)

{

 if (sovp(i) == 1) cout <<i <<" ";

}

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота