rinatabd1
16.08.2021 07:26

Написать программу, которая проверяет следующий факт: все цифры данного четырехзначного числа n различны

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nurbibisaidova3
09.10.2020 15:42

var n,a,b,c,d:integer;

begin

readln(n);

a:=n mod 10;

b:=(n div 10) mod 10;

c:=(n div 100) mod 10;

d:=n div 1000;

if((a-b<>0)or(c-d<>0)or(a-d<>0)) then writeln('Цифры введённого четырёхзначного числа различны') else

writeln('Цифры введённого четырёхзначного числа одинаковы');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота