AlekseyLascot
02.06.2021 00:40

Составить программу, которая формирует массив из 27 случайный чисел от -10 дл 15 и нечетные числа заменяет на 3, остальные уменьшает в 3 раза в паскале

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Makaezhik02
09.10.2020 15:45

const n=27;


var a:array [1..n] of integer;


i:integer;


begin


write('      Исходный массив: ');


for i:=1 to n do


begin


a[i]:=random(26)-10;


write(a[i]:3,' ');


if a[i] mod 2 <> 0 then a[i]:=3


else a[i]:=a[i]-3//уменьшает на 3,т.к. при уменьшении в 3 раза получается тип real, тут или второй массив создавать или взять a[i]:=a[i] div 3 (целочисленное деление)


end;


writeln;


write('Преобразованый массив: ');


for i:=1 to n do write(a[i]:3,' ')


end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота