Составить программу, которая заполняет массив а [1..11] случайными целыми числами в диапазоне от 4 до 18,находит сумму нечётных элементов и находит произведение элементов с четными индексами.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Darina784
04.10.2019 01:30

program fantscrin;

  const n = 11;

  var a: array [1..n] of integer;

      i,s,p: integer;

begin

  for i: =1 to n do

    a[i]: = random(8)+4;

  for i: =1 to n do

    write(a[i], '   ');

   

  s: =0;

  p: =1;

  for i: =1 to n do

    if (i mod 2 = 0) then p: =p*a[i]

                    else s: =s+a[i];  

   

  writeln('');

  writeln('сумма = ',s);

  writeln('произведение = ',p);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота