maximusru05
16.02.2020 08:01

Составить программу вычисления функции y(x)или z(t)в n равномерно распределенных точках диапазона x1< =x< =2 или z1< =z< =z2. выполнять с использованием цикла while и repeat

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Лера15012003
05.11.2021 02:17

C++:

#include <iostream>

using namespace std;

int main() {

long long a, b, m, s = 0; // инициализация чисел

cin >> a >> b >> m; // ввод чисел

for(int i=a; i<=b; i+=m) { // проход циклом for от a до b с шагом m

 s += i; // осуществление суммы

}

cout << s << endl; // вывод суммы

return 0;

}

Python 3:

s = 0

a, b, m = map(int,input().split()) # ввод чисел

for i in range(a, b+1, m):  

   s += i # сложение

print(s) # вывод

Pascal:

var

a, b, m, s :integer;

begin

read(a, b, m); // ввод чисел

s := 0;

while a <= b do begin

     s := s + a; // сумма

     a := a + m; // увеличиваем a

end;

write(s); // выводим сумму

end.

0,0(0 оценок)
Ответ:
Tipaniktuta
08.02.2020 07:57

class Node:

   def __init__(self, val):

       self.l = None

       self.r = None

       self.v = val

class Tree:

   def __init__(self):

       self.root = None

   def getRoot(self):

       return self.root

   def add(self, val):

       if self.root is None:

           self.root = Node(val)

       else:

           self._add(val, self.root)

   def _add(self, val, node):

       if val < node.v:

           if node.l is not None:

               self._add(val, node.l)

           else:

               node.l = Node(val)

       else:

           if node.r is not None:

               self._add(val, node.r)

           else:

               node.r = Node(val)

   def find(self, val):

       if self.root is not None:

           return self._find(val, self.root)

       else:

           return None

   def _find(self, val, node):

       if val == node.v:

           return node

       elif (val < node.v and node.l is not None):

           return self._find(val, node.l)

       elif (val > node.v and node.r is not None):

           return self._find(val, node.r)

   def deleteTree(self):

       # garbage collector will do this for us.  

       self.root = None

   def printTree(self):

       if self.root is not None:

           self._printTree(self.root)

   def _printTree(self, node):

       if node is not None:

           self._printTree(node.l)

           print(str(node.v) + ' ')

           self._printTree(node.r)

#     3

# 0     4

#   2      8

tree = Tree()

tree.add(3)

tree.add(4)

tree.add(0)

tree.add(8)

tree.add(2)

tree.printTree()

print(tree.find(3).v)

print(tree.find(10))

tree.deleteTree()

tree.printTree()

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота