Nikia1
14.09.2022 20:36

Письменный опрос по теме «язык программирования паскаль. основные конструкции языка» в-2 1. программа на языке паскаль начинается со слов: 2. переменные, используемые в программе описываются в разделе: 3. для создания имен переменных можно использовать: 4. пример правильно составленных имен
переменных (5 вариантов): 5. операторы языка паскаль отделяются друг от друга: 6. признаком конца программы написанной на языке паскаль является: 7. напишите синтаксически правильную запись выражения hello_html_m64523c4a.gif 8. какие встроенные функции языка паскаль обозначают словами sqr, abs,
div : 9. какие значения примут переменные a, b после выполнения серии команд: a: =-5; b: =5; a: =a+b; b: =a-b; a: =a-b; 10. что будет отображено на экране после выполнения серии команд (писать из расчета 1-клетка=1-символ): a: =20; b: =0; c: =4; writeln(‘с новым ’,a,b); write(b,c);
writeln(‘ ! ’); 11. запишите последовательность команд, в результате выполнения которых будет найдено наименьшее значение переменных a и b: 12. какую последовательность чисел выведет на экран серия команд: for i: =-15 to 5 do begin write(i): end; 13. какую последовательность чисел выведет на
экран серия команд: a: =0; while a< =10 do begin writeln(a); a: =a+2; end: 14. какую последовательность чисел выведет на экран серия команд: a: =3; repeat a: =a+3; write(a); until a< 15; 15. запишите серию команд, отображающую на экране последовательность чисел: 6 4 2 0 -2 -4 -6 16.
в чем отличие этих операторов: begin …. end. и begin … end; . 17.запишите алгоритм подсчета произведения 10 произвольно введенных чисел. 18.запишите алгоритм вложенных циклов для таблицы: 1 22 333 4444 55555

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nikitabordkin
22.02.2021 03:54
В цикле проверяете (a mod 2) равно ли нулю, то бишь равен ли нулю остаток. Если да - число четное. одновременно с этим первое четное число кладете в переменную max, а остальные четные сравниваете с этой переменной, если какое-то число больше - его кладете в переменную max. Ясно? Если нет, могу написать программу, но лучше чтобы вам было ясно

UPD: можно через массивы, но это не хардкорно

a, max, counter   :   integer;
begin
max := 0;
for counter = 1 To 15 Do
   begin
   writeln("Write ur number:");
   readln(a);
   if (a mod 2) = 0 then 
       if a > max then max := a;
   end;
writeln(max);
readln();
end.

–––––––––––––––––––––––––––––––––––
Вам Б-г

   
0,0(0 оценок)
Ответ:
mishany111222333444
02.09.2021 15:57

Для начала отметим, что переправа не состоится только в одном случае : если число разбойников будет превышать число купцов на берегу.
Итак, пусть берег, на котором стоят три купца и три разбойника , будет называться первым, а берег на который нужно перебраться - вторым. Попробуем вместить в двухместную лодку двух купцов, тогда на первом берегу останется 1 купец и 3 забойника, по условию это недопустимо, идем дальше: в лодку садятся один купец и один разбойник, на берегу остаются два купца и два разбойника, этот расклад нам подходит с него и начнем.
1 рейс- в лодку садятся 1 купец и 1 разбойник и переправляются на второй берег, на нем оставим купца(1 разбойник всегда будет находиться в лодке и переправлять остальных) На первом берегу 2 купца, 2 разбойника(2к;2р)
2 рейс - возвращение к первому берегу
3 рейс- в лодку садится 1 разбойник, т. к. если сядет 1 купец то разбойников на первом берегу будет больше, переправа на второй берег (2к;1р)
4 рейс - возвращение
5 рейс - в лодку садится 1 купец, (1к;1р), переправа
6 рейс - возвращение
7 рейс -в лодку садится 1 разбойник (1к;0 р), переправа
8 рейс - возвращение
9 рейс - в лодку садится 1 купец (0к;0р), переправа 1 купца и 1 разбойника
ответ:Переправа состоялась за 9 рейсов, пострадавших не обнаружено.

как то так)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота