diasline
03.12.2021 08:56

Напишите программу, которая вычисляет длины окружностей с радиусом от 21 до 30. в паскале.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
VafaMurad
04.04.2022 16:30
Const PTR = 10;
type razbivka = array[0..PTR] of byte;
var n, i, z, k: byte;
x: razbivka;
procedure p(var x: razbivka; var z: byte);
var i, j, s: byte;
begin
i := z - 1;
s := x[z];
while (i > 1) and ( x[i - 1] <= x[i] ) do
begin
s := s + x[i];
dec(i);
end;
inc( x[i] );
z := i + s - 1;
for j := i + 1 to z do
x[j] := 1;
end;
begin
write('Введите число: ');
readln(n);
write(n,' = ');
z := n;
for i := 1 to z do
x[i] := 1;
for i := 1 to n do begin
if i > 1 then write(' + ');
write( x[i], '' );
end;
writeln;
repeat
p( x, z );
inc(k);
write( n,' = ' );
for i := 1 to z do begin
if i > 1 then write(' + ');
write( x[i], '' );
end;
writeln;
until z = 1;
end.

p.s: нашел в интернете для вас вариант с рекурсией. Сами можете убедиться, что с ней только хуже (по быстродействию уж точно)

const  m = 100;
var  a: array[1..m] of integer;
k, n: integer;
procedure p(j,n: integer);
var  i: integer;
begin if ( n = 0 ) and ( k > 1 ) then
begin  for i := 1 to k do
write( a[i] : 4 );
writeln;
end else for i := j to n do
begin
Inc(k);
a[k] := i;
p( j, n - i );
Dec(k);
end;
end;
begin
write('Введите число: ');
readln(n);
k := 0;
p(1,n);
end.

значения PTR и m можно поставить и больше, но тогда я не ручаюсь)
0,0(0 оценок)
Ответ:
prohov14
30.10.2022 05:48
Program ex;

// Функция для определения из двух чисел минимальное
function min(a, b: real): real;
begin
    if (a > b) then min := b else min := a
end;

// Функция для определения из двух чисел максимальное
function max2(a, b: real): real;
begin
    if (a > b) then max2 := a else max2 := b
end;

// Функция для определения из трех чисел максимальное
function max3(a, b, c: real): real;
begin
    // Сначала определяем максимальное из первых двух чисел,
    // затем у нас останется два числа и нам остается определить
    // максимальное из них
    max3 := max2(max2(a, b), c);
end;

var
    x, y, z, d, max_int: real;
begin
    writeln('Введите 4 числа');
    readln(x, y, z, d);
    max_int := max3(min(x, y), min(x, z), min(z, d));
    writeln(max_int);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота