9petya
02.02.2021 10:29

Pascal для заданной функции t=cos(m²)+sin(m+m/2.4)-√m-(1.2) вывести на экран значения функции которые лежат в пределах от -2 до 0 и соответствующие им значения аргумента на отрезке m∈[a,6] с шагом h=0,3

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Dead94
30.03.2020 13:31

const n = 10; //В константе n указаваеи количество элементов в массиве

var a:array[1..n]of integer;

i,s,max,min:integer;

begin

write('Массив: '); //Вывод на экран слова "Массив: "

for i:= 1 to n do //Цикл с параметром для последовательной обработки массива

begin

a[i]:= random(21)-10; //Заполнение массива случайными числами из промежутка [-10,10]

if (a[i]>0){//Проверяем положительный элемент или нет} and (a[i] mod 2 = 0){//Проверяем чётный элемент или нет} then s:=s+1; //В переменной s будет считаться количество чётных положительных элементов при выполнении, указанных условий

write(a[i],'  ') //Вывод на экран массива в строку

end;

writeln; //Переход на новыю строку

if s=0 then write('Чётных положительных элементов в массиве нет') //Вывод на экран сообщения "Чётных положительных элементов в массиве нет" и завершение программы

else //Продолжении программы при нахождении хотя бы 1-го чётного положительного элемента

begin

max:=2; //Т.к. 2 минимальное чётное положительное число, то присваиваем это значение переменной max

for i:= 1 to n do //Поиск max элемента

if (a[i]>0) and (a[i] mod 2 = 0) and (a[i]>max){//Проверяем больше текущий элемент max или нет} then max:=a[i]; //Присваиваем переменной max значение текущего элемента при выполнении, указанных условий

min:=max; //Т.к. max значение элемента массива уже найдено, то переменной min присваиваем значение переменной max

for i:= 1 to n do //Поиск min элемента

if (a[i]>0) and (a[i] mod 2 = 0) and (a[i]<min){//Проверяем меньше текущий элемент min или нет} then min:=a[i]; //Присваиваем переменной min значение текущего элемента при выполнении, указанных условий

if max=min then write ('Максимальным и минимальным чётным положительным элементом является один и тот же элемент: ',max) //Вывод на экран результатов

else

begin

writeLn('Максимальный чётный положительный элемент: ',max);//Вывод на экран результатов

write('Минимальный  чётный положительный элемент: ',min)//Вывод на экран результатов

end

end

end.

0,0(0 оценок)
Ответ:
242Bob
30.03.2020 13:31

1

Написать программу ввода с клавиатуры и вывода на экран значений одномерного массива

16.04.2010, 08:15. Просмотров 159492. ответов 17

Метки нет (Все метки)

№1.

Написать программу ввода с клавиатуры и вывода на экран значений одномерного массива А, состоящего из n вещественных элементов (n=10). Найти сумму элементов этого массива и вывести ее на экран.

№2.

Используя оператор выбора, написать программу которая запрашивает у пользователя номер месяца и выводит на экран соответствующее название времени года. В случае если пользователь укажет недопустимое число, программа должна вывести сообщение “Ошибка вывода данных. Повторите ввод”.

№3.

Дан одномерный массив В из n вещественных элементов (n=10). Написать программу, которая вводит значения элементов этого массива с клавиатуры, выводит элементы массива одной строкой, находит наибольший элемент и выводит результат поиска на экран.

№4.

Задана некоторая строка S$. Дано число k и слово а$. Вставить в строку после k-ого символа слово а$, результат вывести на экран.

№5.

Составить программу, которая 100 элементов одномерного массива d заполняет квадратами первых ста целых чисел и выводит их на экран.

№6.

Ввести с клавиатуры значения n вещественных элементов массива с (n = 10), посчитать количество отрицательных и сумму положительных элементов. Результаты вывести на экран.

№7.

Написать программу, которая, используя генератор случайных величин выводит на экран пример на умножение 2-х случайных однозначных чисел, запрашивает ответ пользователя, проверяет его и выводит сообщение “ Правильно!” или “Вы ошиблись” и правильный ответ.

Ниже приведён рекомендуемый вид экрана во время работы программы:

Сколько будет 6*7 ?

Введите ответ и нажмите <Enter>

-> 56

Вы ошиблись. 6*7 = 42.

№8.

Написать программу, которая используя функции mod (остаток от деления) и div (целая часть от деления) находит сумму чисел любого трехзначного числа, число вводится с клавиатуры.

№9

Написать программу подсчета количества чисел кратных 7 на отрезке от 40 до 120. Результат вывести на экран.

0

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота