ichmaelz
24.12.2021 00:16

Составить программу паскаль. мальчик купил в магазине n порций мороженного по цене 120 руб. и k плиток шоколада по цене 3800 руб. сколько всего потратил мальчик.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kurban052
11.09.2021 22:57

Відповідь: 1.Циклічними називаються обчислювальні процеси, в яких неодноразово виконуються одні й ті ж дії, але з різними даними.

2.Цикл із передумовою (або цикл-«поки») — це цикл, у якому тіло циклу виконується тільки у разі виконання умови, заданої перед тілом циклу. Якщо умова стає невірною, то робота циклу припиняється і керування передається оператору, наступному за оператором циклу. На мові Паскаль оператор циклу з перед­умовою ще називається «циклом While-Do».

WHILE <умова> DO <оператор>;

Приклад: обчислення суми перших 100 натуральних чисел методом послідовного додавання.

m:=1; S: =0;

WHILE m<=100 DO

begin

S:=S+m;

m:=m+1;

end;

3.Цикл із післяумовою (або цикл-«до») — це цикл, у якому тіло циклу виконується доти, поки умова, задана після тіла циклу, не стане правильною. Якщо умова стає правильною, то робота циклу припиняється й управління передається оператору, наступному за оператором циклу. На мові Паскаль оператор циклу з після­умовою ще називається «цикл Repeat-Until».

REPEAT <оператор> UNTIL <умова>;

Приклад: обчислення суми перших 100 натуральних чисел методом послідовного додавання.

m:= 0; S: = 0;

REPEAT

m:=m +1;

S:=S+m;

UNTIL m >= 100;

4.Загальний вигляд оператора циклу з параметром (з лічильником):

for <параметр циклу>:=N1 to N2 do <тіло циклу >; де N1 та N2 - початкове та кінцеве значення параметра циклу, тіло циклу може бути або складеним оператором. <Параметр циклу > ще називають лічильником циклу. Оператор for забезпечує виконання тіла циклу до тих пір, поки не будуть перебрані всі значення параметра циклу від початкового до кінцевого. Параметр циклу, його початкове та кінцеве значення повинні бути одного і того ж скалярного типу. При цьому можливий будь який стандартний тип, крім real. Якщо N1 та N2 цілі числа, а параметр циклу - цілочисельна змінна, то крок завжди рівний одиниці.

Приклад.  s:=0; for i:=1 to 20 do s:=s+i;

Для i=1, 2, 3,... , 20 буде виконуватись оператор присвоєння

S:=S+i, який накопичує в змінній S суму перших 20 натуральних чисел. Якщо N1 та N2-символьного типу, а їх значення відповідно рівні 'A' та 'Z', то параметр циклу прийматиме послідовні значення, які співпадають з алфавітом: A, B, C, D E .., Z.

5.Якщо умова у вказівці повторення хибна при першій же перевірці, тотіло циклу не виконується жодного разу. Умова вказівки є умовоювходження в цикл.2. Умову вказівки повторення з передумовою необхідно підбирати такимчином, щоб в деякий момент вона змінила своє значення з TRUE на FALSE,інакше виникне ситуація “зациклювання” програми.3. Програмісту необхідно самому потурбуватись про необхідністьзбільшення (зменшення) лічильника циклу на 1. Це можна зробити такимчином І:=І+1.4. Входження в тіло вказівки повторення можливе тільки через заголовокцієї вказівки.

6.Рекурентним співвідношенням називається формула виду an+1=F(an,an-1,...,an-k+1), де F деяка функція від k аргументів, яка дозволяє обчислити наступні члени числової послідовності через значення попередніх членів.

7.- не знаю

8.- не знаю

Пояснення:

0,0(0 оценок)
Ответ:
Abigael
22.05.2021 22:19
Program ZvonPOBEDITEL;var i,n,k,i_1,i_2,d_1,d_2: integer;c: char;s,s_1,s_2: string;begin i_1:=0; i_2:=0; d_1:=1; d_2:=1; readln(n); for i:=1 to n do begin  c:='a';  s:='';  while c<>' ' do  begin   read(c);   s:=s+c;  end;  read(c);  while c<>' ' do  begin   s:=s+c;   read(c);  end;  read(c);  while c<>' ' do  begin   read(c);  end;  readln(k);  if (k=i_1) and (i<>1) then d_1:=d_1+1;  if k>i_1 then   begin   i_2:=i_1;   i_1:=k;   s_2:=s_1;   s_1:=s;   d_2:=d_1;   d_1:=1;  end;  if (k=i_2) and (i<>1) then d_2:=d_2+1;  if (k>i_2) and (k<i_1) then   begin    i_2:=k;   s_2:=s;   d_2:=1;  end; end; if (i_1<=200) and (d_1=1) then writeln(s_1); if (i_1<=200) and (d_1<>1)then writeln(d_1); if (i_1>200) and (d_2=1) then writeln(s_2); if (i_1>200) and (d_2<>1) then writeln (d_2);end. Это сугубо мое решение за копирайтинг отвешу люлей. И к тому же сдесь есть одна ошибка о которой знаю только я, так сказать один из частных случаев здесь не прощитывается, по этому поломайте голову, Ха-Ха-Ха...
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота