niktoto
15.05.2020 18:09

Написать программу на паскале:
в школе альтаир занятия проводятся каждый день по 3 или 5 уроков. миша приехал на n уроков. необходимо определить сколько у него будет дней по 5 уроков, а сколько по 3, при этом суммарное количество дней должно быть минимальным.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Vakluver
13.02.2023 21:59

Программа представлена на скрине.

Далее под константой будет пониматься макроопределение (символическая константа)

Были созданы константы для обозначения флагов ингредиентов. Им даны осмысленные названия. Также была создана константа для формирования пустого заказа.

int ingredientsCount(Pizza&); - возвращает количество ингредиентов.

void addCheese(Pizza&); - добавляет в заказ сыр

void removeOnion(Pizza&); -  убирает из заказа лук

void togglePineapple(Pizza&);  - переключает ананасы

void addOnionIfMushroomsExist(Pizza&); - добавляет лук если есть грибы


Задача на побитые операции в c++ В пиццерии для заказа пиццы используют стенд заказов, на котором по
0,0(0 оценок)
Ответ:
dimoncool67
09.07.2021 19:30
PascalВыделить код
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
program lab_10_41;
type phone=record
nomer:integer;
day:integer;
mesyac:integer;
god:integer;
chas:integer;
minuta:integer;
kod:integer;
othernomer:integer;
time:integer;
categoriya:integer;
tarif:real;
end;
var a:array [1..20] of phone;
m,max,k,i,n:integer;
b:string;
begin
writeln('Введите количество разговоров:');
readln(n);
for i:= 1 to n do
begin
a[i].nomer:=111111+random(888888);
a[i].day:=1+random(30);
a[i].mesyac:=1+random(11);
a[i].god:=2000+random(12);
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота