Bernardeschi
18.08.2020 04:26

Амаленькому коле не нравится, когда числа в массиве не отсортированы по возрастанию (если быть точным, по неубыванию, но коля таких слов не знает). вот кто придумал дарить детям неотсортированные массивы? мы не знаем, но коля сегодня получил именно такой подарок. он даже решил посчитать число таких пар индексов массива (i,j), что iaj, чтобы хоть как-то измерить силу своей ненависти к подаренному ему массиву a и тому человеку, который это сделал. коля устал злиться, но сумеет сделать ещё ровно одно действие – поменять два элемента массива a местами. ручки у него короткие, так что коля может поменять местами только соседние элементы массива a (то есть такие элементы, индексы которых различаются не более чем на 1). определите количество которыми коля может уменьшить описанное выше число пар индексов. два считаются различными, если существует индекс, который встречается только в одной из двух пар индексов, описывающих эти два

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ksenia777angel
10.10.2020 10:52

col_el = int (input ())

ls = list (map (int, input ().split (maxsplit = col_el)))

s = 0

for i in range (len (ls)):

   if i + 1 < len (ls) and ls [i] > ls [i + 1]:

       s = s + 1

print (s)

Объяснение:

Надо просто найти количество всех случаев где Коля может переставить местами два числа.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота