ададсжсжэвжю
31.05.2020 02:21

Написать программу для pascal abc.дан массив действительных чисел,размерность которого n.подсчитать,сколькоив нем отрицательных,положительных и нулевых элементов.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
dawka09
13.07.2020 15:25
Program aaa;
var 
a,b,c,n,i:longint;
M:array[1..1000000] of real;
begin
read(n);                //
for i:=1 to n do      //если считывать массив не нужно, то удалить   
  read(M[i]);          //   
a:=0;
b:=0;
c:=0;
for i:=1 to n do
begin
  if M[i]>0 then inc(a);
  if M[i]=0 then inc(b);
  if M[i]<0 then inc(c)
end;
writeln('положительных элементов:',a);
writeln('нулевых элементов:',b);
writeln('отрицательных элементов:',c)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота