saitieva03
08.06.2022 06:21

Тема: знакомство с языком паскаль
1 уровень сложности и
1. а) набрать в редакторе системы турбо-паскаль следующую программу:
program my;
var a,b,c,s: integer;
begin
readln(a);
readln(b);
readln(c);
s: =a*b*с;
writeln(s)
end.
6) откомпилировать набранную программу и исправить ошибки.
в) запустить данную программу на выполнение и проверить правильность ее ра-
боты для чисел 2, 4 и 6.
г) запустить данную программу на выполнение и проверить правильность её рабо-
ты для чисел 1, ои-1.
д) запустить данную программу на выполнение и проверить правильность ее ра-
боты для чисел -2, зи 10.
2. написать программу, которая присваивает целой переменной а значение 10 и
выводит это значение на экран.
3. написать программу, которая запрашивает ввод целого числа в переменную в и
выводит это число на экран. проверить правильность работы программы на числах 1, -
5, 256, 10455.
4. написать программу, которая запрашивает ввод вещественного числа в пере-

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
SuperGirl1111468
14.01.2020 04:14
8
Укажите тип переменной для выражения: ((х>=-2) и (x<=2))
Если х, то
A. целый
B. вещественный
Если все выражение то
D. логический

9
Для выражения y=(3a+b)/2 исходными данными будут...
A. a,b

10
Для выражения y=(a+4b) при а=6, b=8 результат будет равен...
D. 38

11
Неправильным является имя величины...
C. 12авс

12
Сумма двух слагаемых а и b, деленная на сумму двух других
слагаемых c и d запишется как...
C. (a+b)/(c+d)

13
Имеется серия команд
f:=2;
f:=f*f;
f:=f*f;
f:=f*f.
Чему равен результат?
B. 256

14
Линейным называется алгоритм, в котором...
A. команды выполняются одна за другой в порядке их следования

15
Строка:
readln (A);
выполняет...
A. ввод в программу значения переменной А

16
Y:=5;
какой оператор выведет надпись Y=5?
A. writeln ( ' Y = ' , Y ) ;

17
а:=2; b:=8;
S:=а+b;
После выполненных последовательно данных трех команд переменная S принимает значение
равное ...
A. 10

18
S:=7;
S:=23;
writeln (S);
Какое значение будет выведено на экран?
A. 23

19
S:=1;
S:=S+5:
Writeln (S/2);
Что будет выведено на экране?
A. 3

20
A:=2; B:=5: B:=B-A; S:=A+B;
writeln (S);
Что будет выведено на экран?
A. 5

21
Для ввода данных в блок-схемах используют фигуру...
A. параллелограмм

22
Для выполнения вычислительных действий в блок-схемах используют фигуру...
C. прямоугольник

23
Определите результат работы фрагмента программы:
writeln ( ' 5+5= ' , 5+5 );
A. 5+5=10

24
Действие оператора WRITELN - это...
A. переход на новую строку

25
Сколько переменных нужно ввести для вычисления площади и периметра квадрата?
A. одну

26
Найдите логически неверно записанную последовательность команд.
те что имеют непонятные логические ходы
A. writeln (S); A:=A*2; readln (A,B); S:=A+B;
C. A:=A*2; readln (A,B); S:=A+B; Writeln (S);
D. readln (A,B); S:=A+B; A:=A*2; writeln (S);
27
Как будут выведены значения:
Writeln (A); Writeln (B); ?
A. в столбик
0,0(0 оценок)
Ответ:
arianaforever1
06.05.2023 01:44
Вообще надо думать своей головой ты же учишься в ШП)Hо если ты хочешь тупо все списывать и тебя заставляют их выполнять держи, мне не жалко:a = input()

d = len(a)

print(a[0:1].upper() + a[1:d].lower())

Объяснение(Если ты это и вправду читаешь, то тебе уже интересно, как это работает, это уже хорошо):

Запрашиваем переменную a

Переменная d = сколько в переменной a символов

выводим(от переменной a первый символ капсом + присоединяем остальное слово мал.буквами

Все элементарно и понятно! Учись, кхм.. То есть списывай на здоровье!

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота