ralina27
23.09.2022 02:27

Написать программу для решения следующих задач:
1) Вывести на экран все двузначные числа:
а) В столбик
б) В строчку
2) Вывести на экран целые числа из интервала [-15; 10];
3) Вывести на экран целые числа из интервала [-5; 5] в обратном порядке;
4) Вывести на экран все четные двузначные числа;
5) Найти и вывести на экран сумму всех двузначных чисел;
6) Найти и вывести на экран сумму всех целых чисел из интервала [-100; 51];

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ladysachenko20
24.04.2020 08:30

1) 

var a:array [1..100] of integer;

n,i:integer;

begin

for i:=10 to 99 do begin

a[i]:=i;

if (a[i] mod n=0) then writeln(a[i]);

end;

end.

 

 2)

var a:array [1..100] of integer;

n,k,i,x,y,z: integer;

begin

readln(n,k);

for i:=n to k do begin

a[i]:=i;

x:=a[i] mod 10;

y:=a[i] div 10;

z:=y mod 10;

y:=y div 10;

if (x=y) or (x=z) or (y=z) then writeln(a[i]);

end;

end.

 

 3)

 var a,n,an,na: integer;

begin

readln(a,n);

if (a>0) and (b>0) then begin

an:=a*10+n;

na:=n*10+a else writeln('Введены неверные числа!');

end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота