198219821982
28.02.2020 11:28

2.1. Определите, значение какой функции вычисляет написанная программа? Оформить таблицу вычислений
№ x y
1 -2
2 0
3 6

program Virajenie;
uses crt;
var
x,y:real;
begin
clrscr;
write('Значение x=');
readln(x);
if (x<0) then
y:=-x
else
y:=x+2;
writeln('При x=',x:8:2,' y=',y:8:2);
readkey
end.
2.2. (БИД) Попробуйте сформулировать, что определяет данная программа. Оформить таблицу вычислений
№ Первое число Второе число Вывод
1 2 8
2 11 7
3 25 25

program Sravnenie;
uses crt;
var
a,b:real;
Begin
clrscr;
write('Сравниваемые числа ');
readln(a,b);
if (a=b) then writeln('Числа равны')
else
if (a>b) then writeln('Первое число больше')
else writeln('Второе число больше');
readkey
end.

2.3. Вычислить значение выражения …………. для заданного значения x. Оформить таблицу вычислений (пользуясь программой, данной ниже, заполните пропуски в условии задачи и таблице)

№ x ?
1 -3
2 0
3 5

program Virajenie;
uses crt;
var
x,y:real;
begin
clrscr;
write('Значение x=');
readln(x);
if (x=0) then
writeln('При x=',x:8:2,' выражение не определено')
else
begin
y:=x+1/x;
writeln('При x=',x:8:2,' y=',y:8:2)
end;
readkey
end.

Записать программы
2.4 Проверить, является ли введенное с клавиатуры целое число четным.

2.5 Проверить оканчивается ли целое число на 0.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Tamilla19
13.10.2020 23:40

2.1)

2

2

8

2.2)

Второе число больше

Первое число больше

Числа равны

2.3)

-3,33

Выражение не определено

5,20

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота