dianajalagonia
20.10.2022 02:57

на си++ требовалось написать программу, при выполнении которой с клавиатуры считываются координаты точки на плоскости (x, y — действительные числа) и определяется принадлежность этой точки заданной закрашенной области (включая границы). ученик написал такую программу: #include using namespace std; int main (){ float x, у; cin > > x > > y; if (y > = 1-х) { if (y < = 2-2*x*x) cout < < "принадлежит"; } else if (y > = x*x-5) cout < < "принадлежит"; else cout < < "не принадлежит"; } укажите, как нужно доработать программу, чтобы не было случаев её неправильной работы. (это можно сделать несколькими достаточно указать любой доработки исходной программы.)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
bandygan666
30.06.2021 12:20
//Pascal ABC.NET v3.1 сборка 1172

var
  ar: array of integer;
  n, k2, k3, k4, k5, i: integer;
  r: real;

begin
  write('Сколько учеников?');
  readln(n);
  setlength(ar, n);
  writeln('Введите оценки:');
  for i := 0 to n - 1 do
  begin
    readln(ar[i]);
    case ar[i] of
      2: inc(k2);
      3: inc(k3);
      4: inc(k4);
      5: inc(k5);
    else
      writeln('Не оценка');
      exit;
    end;
  end;
  writeln('2:', k2);
  writeln('3:', k3);
  writeln('4:', k4);
  writeln('5:', k5);
  write('Успеваемость=', (k3 + k4 + k5) / n * 100:0:1);
end.

Пример ввода:
Сколько учеников?6
Введите оценки:
2
2
3
4
5
5
Пример вывода:
2:2
3:1
4:1
5:2
Успеваемость=66.7
0,0(0 оценок)
Ответ:
никлася
20.06.2020 09:37
№1.
Тысячи путей ведут к заблуждению, к истине - только один.
Для начала надо посчитать, сколько всего символов в данном предложении, следует считать знаки препинания и пробелы. 
Посчитав все знаки (Итого:57), мы получаем, что вес предложения 57 байт, переводим в биты, то есть умножаем на 8 (1 байт = 8 бит):
57*8=456.

№2.
Кодировка Unicode - это кодировка, каждый символ которой весит 16 бит. Итак, я посчитала количество знаков в предложении (Итого:32). Дальше: 16*32=512 бит.

№3.
Итак, мы видим, что из 16-битной кодировки получилась 8-битная, а это значит, что она уменьшилась вдвое.
8x=800
x=100 (у тебя ошибка, я посмотрела аналогичные задания, отличающиеся только значениями)

№4 допишу в комментарии.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота