Чему будет равна переменная «c» после выполнения программы: a := 24; b := 5; b := a div b + b; c := a mod b + a; *

2. Чему будет равна переменная «c» после выполнения программы: a := 26; b := 6; c := a mod b + b;

3. Чему будет равна переменная «c» после выполнения программы: a := 24; b := 5; b := a mod b + 4; c := a mod b + 1; *

4. Чему будет равна переменная «c» после выполнения программы: a := 22; b := 4; b := a mod b; c := a div (b + 1); *

5. Определите значение переменной «a» после выполнения фрагмента программы: a := 10; if a > 5 then a := 12; *

6.Определите значение переменной «a» после выполнения фрагмента программы: a := 10; if a < 5 then a := a + 12 else a := a - 7; if a < 5 then a := a + 12 else a := a - 7; *

7. Определите значение переменной «a» после выполнения фрагмента программы: a := 10; b := 5; if (a > 5) and (a < b) then a := a - 5; *

8. Определите значение переменной «a» после выполнения фрагмента программы: a := 10; b := 5; if (a > 1) or (a < b) then a := a - 5; if (a > 1) and (a = b) then a := a - 5; *

9. Определите значение переменной «a» после выполнения фрагмента программы: a := 10; b := 5; if (a > 1) and (a < b) then a := a - 5; if (a > 1) and (a = b) then a := a - 5; *

10. Какую логическую операцию нужно добавить в программу вместо многоточия, чтобы значение переменной «a» после выполнения фрагмента программы стало равно 3? a := 10; b := 5; if (a < 1) ... (a > b) then a := a - 7 else a := a + 7; *

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Kreyda
22.08.2022 02:07
//1. Переборный алгоритм Евклида (цикл repeat)

var a, b, с: integer; 

begin

  write('Введите два числа: ');

  readln(a, b);

  if a < b then с := a + 1 else с := b + 1;

repeat с := с - 1

  until (a mod с = 0) and (b mod с = 0);

  write('NOD = ', с)

end.

 

//2. Алгоритм с вычитанием (цикл while)

var  a, b: integer;

begin

  write('a = ');

  readln(a);

  write('b = ');

  readln(b);

  while a <> b do

    if a > b then

      a := a - b

    else

      b := b - a;

  writeln('NOD = ', a);

end.

0,0(0 оценок)
Ответ:
Mila1515
26.03.2022 08:57
Вопрос с подвохом, пропускная меряется не от возможной передачи на стороне провайдера или пользователя, а от версии протокола 2СH (2 цэ-аш). Рассмотрим 2 последние версии. Протокол 2015 года поддерживал пропускную вплоть до 20 MB/WEBM. Стандарт нового протокола поразили многих экспертов, скорость была снижена вдвое. Но сделано это было в связи с отказом многих производителей сетевого оборудования устанавливать расширяющие микросхемы PassCODE для поддержки тех самых 20 MB/WEBM. Может в будущем, с большим распространением PassCODE пропускную поднимут, но пока приходится с этими ограничениями смирится и перекодировать WEBM что несомненно, приведет к ухудшению их качества. 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота