анна1796
09.06.2020 09:50

РЕШИТЬ ЗАДАЧИ ПО ИНФОРМАТИКЕ Составить программу, которая изменит все элементы массива С [1..100] С ЧЕТНЫМИ НОМЕРАМИ в 2 раза. Полученный массив вывести на экран

2) Составить программу, которая выводит на экран номер и значение элементов массива N[1..K], КОТОРЫЕ ОКАНЧИВАЮТСЯ НА 1.

3) В массиве С[1..50] определить произведение элементов, имеющих положительные значения и нечетный номер. Результат вывести на экран.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
КириллАлек
27.07.2021 01:06

ОбъясОтличник

program prog;

uses crt;

var a,b,v:integer;

begin

clrscr;

write('Возраст Антона = ');

readln(a);

write('Возраст Бориса = ');

readln(b);

write('Возраст Виктора = ');

readln(v);

writeln;

if (a>b)and(a>v) then writeln('Антон старше всех.');

if (b>a)and(b>v) then writeln('Борис старше всех.');

if (v>a)and(v>b) then writeln('Виктор старше всех.');

if (a=b)and(a>v) then writeln('Антон и Борис старше Виктора');

if (a=v)and(a>b) then writeln('Антон и Виктор старше Бориса');

if (b=v)and(b>a) then writeln('Борис и Виктор старше Антона');

if (a=b)and(a=v) then writeln('Антон,Борис и Виктор одного возраста');

end.

Подробнее - на -

0,0(0 оценок)
Ответ:
danieldsha1234
02.04.2022 03:22
Наибольшее возможное значение выражения (F+O+X+E)*(F*R*D*D) = 236196. Прилагаю небольшой скрипт на Python. Простенькая задачка на корректную организацию перебора с использованием вложенных циклов:

max_num = 0
for f in xrange(10):   
    for o in xrange(10):
        for x in xrange(10):
            for e in xrange(10):
                 for r in xrange(10):
                      for d in xrange(10):
                            b = f*r*d*d
                            if b == 0:
                                 continue
                            num = (f + o + x + e) * b
                            if num > max_num:
                                 max_num = num

print "Maximum value of (F+O+X+E)*(F*R*D*D) is: %i" % max_num

Решение можно получить гораздо проще, если догадаться, что наибольшее значение выражения достигается, когда сумма F+O+X+E и произведение F*R*D*D являются максимальными. Это одновременно происходит, когда все цифры равны 9: (9+9+9+9)*9*9*9*9 = 236196
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота